Skip to content
Save up to 30% on Select Items
Save up to 30% on Select Items

LATNEX SPECTRUM ANALYZER USER MANUAL & SOFTWARE DOWNLOADS

User Manuals

LATNEX SPA User Manual

LATNEX Signal Generator Manual

LATNEX SPA Firmware

LATNEX Spectrum Analyzer Firmware v1.31

LATNEX Spectrum Analyzer Standard firmware.
Only for Handheld Spectrum Analyzer Standard (7 buttons)

Only for Handheld Spectrum Analyzer - DO NOT install this software on signal generator

Suitable for the following models:

  • LATNEX SPA-6G
  • LATNEX SPA-3G

LATNEX SPA-50K Firmware v3.16

LATNEX SPA-50K firmware.
Only for Handheld Spectrum Analyzer 50K model (9 buttons)

Firmware Upgrade Instructions included in the download package
Apple Mac users please visit specific instructions and software on this link

LATNEX RF-SG6 Signal Generator Firmware v1.31

LATNEX Signal Generator firmware.
Only for Handheld Signal Generator

This firmware is only suitable for Signal Generator models, DO NOT install on spectrum analyzer models

Free Software downloads for Windows

LATNEX SPA for Windows XP/Vista/Win7/Win8.x/Win10 and Windows Server - v2.1.2007

For use with firmware v1.31 and v3.16

Supported on Windows XP / Vista / Win7 / Win8.x / Win10 and Windows Server

Note: WindowsXP computers may require prior install Microsoft Windows Installer 4.5 Hotfix from this link.

Note: The installer will automatically detect and install Microsoft .NET 4 if required.

USB Drivers from Silicon Labs for WindowsXP/Vista/7/8.1/10 - 32 and 64 bits - version 6.7

USB bridge driver. See Silabs site for more info.

LATNEX SPA System Check Tool 

This tool inspects configuration parameters, system drivers and USB connections for diagnosis purposes. It can run anytime is needed to determine source of problems in a computer configuration, if connection with your LATNEX SPA is failing or the tool has any issues.

Download

Free software for MacOS 

LATNEX SPA Preset Manager for Mac

Version v2.00.1902 - for use with firmware v1.26 and v3.06 or newer

Requires firmware v1.26 for Analyzer Standard, v3.06 for Analyzer PLUS and ProAudio or newer

Available in all MacOS versions with Mono support.

SPATouch for Mac - Latest Version

Version v1.4 - for use with firmware Standard v1.28 and Plus v3.12 or newer

Supported on macOS 10.11 - 10.14, note touch capabilities are not available in Mac computers to date. This software is not compatible with macOS Catalina.
For running RF Explorer software in Catalina please use our free VM

USB Drivers for Mac

Latest Silicon Labs drivers for MacOS

Download and install Silicon Lab USB drivers is required for MacOS to recognize device connection.

Free Firmware Upgrade downloads for Linux

Latest Firmware for LATNEX SPA-50K Spectrum Analyzer 

Version 3.16

LATNEX SPA-50K firmware.
Only for Handheld Spectrum Analyzer PLUS model (9 buttons)

Important: due to configuration data format, after upgrading to v3.16 you must not downgrade to an earlier version as otherwise calibration data may be lost in your unit.

Note: You may need to manually adjust the Contrast in the CONFIG MENU after upgrading to this firmware version.

Firmware Upgrade Instructions included in the download package
Apple Mac users please visit specific instructions and software on this link

Latest Firmware for LATNEX Spectrum Analyzer Standard

Version 1.31

RF Explorer Spectrum Analyzer Standard firmware.
Only for Handheld Spectrum Analyzer Standard (7 buttons)

DO NOT INSTALL THIS IN SIGNAL GENERATOR

Firmware Upgrade Instructions included in the download package
Apple Mac users please visit specific instructions and software on this link

 

Software for LATNEX SPA IoT modules

SPATouch - Raspbian OS image for Raspberry Pi 4B

This version requires an official 7" touch screen, do not use in other configurations.

Version v1.4.2002 Download link

Note: requires micro-SD card with at least 8GB size

This is a 3GB download. Use standard Raspberry Pi instructions to create the image

SPATouch - Raspbian OS image for Raspberry Pi 4B)

This version can work with any screen connected to the Raspberry.

Version v1.4.2002 Download link

Note: requires micro-SD card with at least 8GB size

This is a 3GB download. Use standard Raspberry Pi instructions to create the image

SPATouch for Raspberry - Latest Version

Version v1.4.2002 - For use with Raspberry Pi 2, 3 and 4 models

To use this version, either upgrade from an earlier Raspberry Pi image including RFETouch already, or follow steps documented to create your own Raspbian setup to correctly work with RFETouch.

More details at www.rf-explorer.com/touch

Note: requires mono from www.mono-project.com installed, recommended mono v5.20

SPATouch - Raspbian OS image for Raspberry Pi 3B+

This version requires an official 7" touch screen, do not use in other configurations.

Version v1.3.1907 Download link

Note: requires micro-SD card with at least 8GB size, you must manually upgrade the RFETouch_bundle binary downloading the latest version after creating the image.

This is a 3GB download. Use standard Raspberry Pi instructions to create the image

SPATouch - Raspbian OS image for Raspberry Pi 3B+

This version can work with any screen connected to the Raspberry.

Version v1.3.1907 Download link

Note: requires micro-SD card with at least 8GB size, you must manually upgrade the RFETouch_bundle binary downloading the latest version after creating the image.

This is a 3GB download. Use standard Raspberry Pi instructions to create the image

SPATouch - Raspbian OS image for Raspberry Pi 3B

This version requires an official 7" touch screen, do not use in other configurations.

Version v1.3.1907 Download link

Note: requires micro-SD card with at least 8GB size, you must manually upgrade the RFETouch_bundle binary downloading the latest version after creating the image.

This is a 3GB download. Use standard Raspberry Pi instructions to create the image

SPATouch - Raspbian OS image for Raspberry Pi 3B

This version can work with any screen connected to the Raspberry.

Version v1.3.1907 Download link

Note: requires micro-SD card with at least 8GB size, you must manually upgrade the RFETouch_bundle binary downloading the latest version after creating the image.

This is a 3GB download. Use standard Raspberry Pi instructions to create the image

Raspbian OS image for Raspberry Pi 1B+

Download link

Note: requires micro-SD card with at least 16GB size

Important: please make sure to upgrade latest libraries from GITHUB, the SD image may not have the latest developments and examples. More details: https://github.com/SPA

This is a 3GB download. Use standard Raspberry Pi instructions to create the image

Raspbian OS image for Raspberry Pi 2B

Download link

Note: requires micro-SD card with at least 8GB size

Important: please make sure to upgrade latest libraries from GITHUB, the SD image may not have the latest developments and examples. More details: https://github.com/SPA

This is a 3GB download. Use standard Raspberry Pi instructions to create the image

Raspbian OS image for Raspberry Pi 3B

Download link

Note: requires micro-SD card with at least 8GB size

Important: please make sure to upgrade latest libraries from GITHUB, the SD image may not have the latest developments and examples. More details: https://github.com/SPA

This is a 3GB download. Use standard Raspberry Pi instructions to create the image

Native Arduino libraries

Support for Arduino Due and Seeeduino

Free software for Linux 

LATNEX SPATouch for Linux - Latest Version

Version v1.4.2002 - for use with firmware Standard v1.28 and Plus v3.12

For Copyright and License note please read this page link.

Supported on Linux kernel 2.6+, tested on Ubuntu 18.04 64bits and Mono 6

Note: requires mono from www.mono-project.com installed, recommended mono v6

LATNEX SPA Preset Manager for Linux - Latest Version

Version v2.00.1902 - for use with firmware v1.26 and v3.06

Requires firmware v1.26 for Analyzer Standard, v3.06 for Analyzer PLUS and ProAudio

LATNEX Signal Generator Tool for Linux - Latest Version

Version v2.00.1905 - for use with firmware v1.31

 

Available in all Linux platforms with Mono support.

 

USB Drivers for Linux

Latest Silicon Labs drivers for Linux

Most modern Linux kernels already include support for Silabs CP2012 driver. Visit link above if your specific distro does not work yet with CP2102 natively.